การทดสอบเจาะระบบสารสนเทศ (Penetration Testing)

Updated: Nov 9, 2020

    เนื่องจากช่วงเวลานี้ผมได้เข้าอบรมหลักสูตร Certified Hacking Forensics Investigator (CHFIv8) ที่มหาวิทยาลัยเทคโนโลยีมหานคร ได้เกิดปัญหาเรื่อง Vmware image ที่ได้รับมาใน

   ในการอบรมครั้งนี้เป็น Vmware Workstation เวอร์ชั่น ซึงไม่สามารถที่จะเปิดบน Vmware Workstation เวอร์ชั่น บนเครื่อง Notebook ของผมได้ ผมจึงได้หาทางแก้ไขและได้เขียนบทความนี้ขึ้นมาดังขั้นตอนดังต่อไปนี้

1. ทำการ Backup ไฟล์ Vmware image ของ Vmware Workstation เวอร์ชั่น 9

2. ทำการแก้ไขไฟล์ Vmware image ที่มีนามสกุล .vmx ยกตัวอย่างชื่อไฟล์ vm2008R2-CHFI.vmx ผมทำการเปิดไฟล์ด้วยโปรแกรม Notepad++ เพื่อการแก้ไขจาก config.version = “9” เป็น config.version = “8” และ virtualHW.version = “9” เป็น virtualHW.version = “8” ดังภาพที่ 1

ภาพที่ 1

หมายเหตุ :: ในกรณีที่ Vmware Workstation ของท่านเป็นเวอร์ชั่น ก็สามารถแก้ไขเป็นเวอร์ชั่น ได้เลย แต่สำหรับท่านใดที่มี Vmware Workstation ต่ำกว่าเวอร์ชั่น ลงไปท่านจะต้องทำการแก้ไข virtual hardware เพิ่มเติมจาก scsi0.virtualDev = “lsisas1068” เป็น scsi0.virtualDev = “lsilogic” เนื่องจาก Vmware Workstation เวอร์ชั่นที่ต่ำกว่าเวอร์ชั่น ไม่รู้จัก virtual hardware

อ้างอิง :: http://communities.vmware.com/thread/338404?start=0&tstart=0